sbt plugin for packaging ConnId (Connectors for Identity Management) framework connector

sbt-connid-pack

Build Status Codacy Badge Download

sbt plugin for packaging ConnId (Connectors for Identity Management) framework connector, for example, can be used to package connectors for midPoint identity management platform.

installation

Add the following line to project/plugins.sbt:

addSbtPlugin("eu.arthepsy.sbt" %% "sbt-connid-pack" % "1.0.0")

This plugin is released both for sbt 0.13 and sbt 1.0.

usage

To enable the plugin:

enablePlugins(ConnIdPackPlugin)

To specify particular connector framework version (default: 1.4.2.35):

connIdVersion in ConnId := "1.4.2.18"

Now just create a package as You normally would and the resulting package will contain required dependencies and meta-information.