discipline

Flexible law checking for Scala

Build Status

Usage

This library is currently available for Scala binary versions 2.10, 2.11 and 2.12.

To use the latest version, include the following in your build.sbt:

libraryDependencies +=
  "org.typelevel" %% "discipline" % "0.7.3"

Binding to test frameworks

Discipline is built against ScalaCheck 1.13.x. There is also a published artifact for scala.js.

There are bindings for Specs2 and ScalaTest. Since Discipline depends on them optionally, you have to add either one to your build explicitly:

libraryDependencies +=
  "org.scalatest" %% "scalatest" % "3.0.1"
  // or
  "org.specs2" %% "specs2" % "3.8.9"