discipline

Join the chat at https://gitter.im/typelevel/discipline

Flexible law checking for Scala

Build Status

Usage

This library is currently available for Scala binary versions 2.11, 2.12, and 2.13.

To use the latest version, include the following in your build.sbt:

libraryDependencies +=
  "org.typelevel" %% "discipline-core" % "1.0.0"

For a little more info see the "Law Enforcement using Discipline" blog post.

Binding to test frameworks

Discipline is built against ScalaCheck 1.14.x. There is also a published artifact for scala.js.

discipline-core is required early each Scala release cycle, so we have chosen to keep this repo minimal. Starting with v1.0.0, please find the framework bindings in their new locations:

Code of Conduct

See the Code of Conduct