scala / scala-java8-compat   1.0.2

Apache License 2.0 GitHub

A Java 8 compatibility kit for Scala.

Scala versions: 3.x 2.13 2.12 2.11 2.10

scala-java8-compat 0.2.0


Group ID:
org.scala-lang.modules
Artifact ID:
scala-java8-compat_2.10
Version:
0.2.0
Release Date:
Jan 18, 2015
Licenses:

libraryDependencies += "org.scala-lang.modules" %% "scala-java8-compat" % "0.2.0"
resolvers += Resolver.bintrayJCenter

Mill build tool

ivy"org.scala-lang.modules::scala-java8-compat:0.2.0"
MavenRepository("https://jcenter.bintray.com")

Scala CLI

//> using dep "org.scala-lang.modules::scala-java8-compat:0.2.0"

Ammonite REPL

import $ivy.`org.scala-lang.modules::scala-java8-compat:0.2.0`
import ammonite._, Resolvers._
val res = Resolver.Http(
  "Bintray's JCenter",
  "Some(https://jcenter.bintray.com)",
  IvyPattern,
  false)
interp.resolvers() = interp.resolvers() :+ res

<dependency>
  <groupId>org.scala-lang.modules</groupId>
  <artifactId>scala-java8-compat_2.10</artifactId>
  <version>0.2.0</version>
</dependency>

compile group: 'org.scala-lang.modules', name: 'scala-java8-compat_2.10', version: '0.2.0'