macro-compat is a small library which allows you to compile macros with Scala 2.10.x which are written to the Scala 2.11/2 macro API.

macro-compat 1.1.1


Group ID:
org.typelevel
Artifact ID:
macro-compat_2.12
Version:
1.1.1
Release Date:
Nov 2, 2016
Licenses:
Files:

libraryDependencies += "org.typelevel" %% "macro-compat" % "1.1.1"

Mill build tool

ivy"org.typelevel::macro-compat:1.1.1"

Scala CLI

//> using lib org.typelevel::macro-compat:1.1.1

Ammonite REPL

import $ivy.`org.typelevel::macro-compat:1.1.1`

<dependency>
  <groupId>org.typelevel</groupId>
  <artifactId>macro-compat_2.12</artifactId>
  <version>1.1.1</version>
</dependency>

compile group: 'org.typelevel', name: 'macro-compat_2.12', version: '1.1.1'