kamon-io / kamon-akka-remote Edit

Kamon Instrumentation for Akka Remote

Version Matrix

Akka Remote Integration

Build Status Gitter Maven Central

Important

In the Kamon 2.0 series we moved all Akka-related instrumentation to the kamon-akka repository. This repository remains here for reference for those using previous Kamon versions.

Getting Started

This module is currently available for Scala 2.10, 2.11 and 2.12, and requires you to start your application using the AspectJ Weaver Agent. Kamon will warn you at startup if you failed to do so.

Supported releases and dependencies are shown below.

kamon-akka-remote-2.4 status jdk scala akka
1.1.0 stable 1.7+, 1.8+ 2.11, 2.12 2.4.x
kamon-akka-remote-2.5 status jdk scala akka
1.1.0 stable 1.8+ 2.11, 2.12 2.5.x

To get started with SBT, simply add the following to your build.sbt or pom.xml file:

libraryDependencies += "io.kamon" %% "kamon-akka-remote-2.5" % "1.1.0"
<dependency>
    <groupId>io.kamon</groupId>
    <artifactId>kamon-kamon-akka-2.5_2.12</artifactId>
    <version>1.1.0</version>
</dependency>